Log in

Login to your account

Username *
Password *
Remember Me

Create an account

Fields marked with an asterisk (*) are required.
Name *
Username *
Password *
Verify password *
Email *
Verify email *
Captcha *
Reload Captcha

AFT Product Tips

5 minutes reading time (1086 words)

How Many Models of the Same System Do You Have?

Well, if the answer is "more than one", then you are probably struggling to deal with way more model files than you need to be.  With all AFT products, the Scenario Manager is an incredibly powerful feature that allows one to model several different cases within a single model file. This includes different operating conditions, multiple pump configurations, different piping, system expansions, hot days, cold days, insulation, fouling and pipe scaling, etc. The list of different cases that can be modeled is essentially endless!

So, I have said it once, and I will say it again...The Scenario Manager is one of the most powerful features of AFT software that will greatly enhance your modeling efficiency and effectiveness by a significant measure!  A while back, I wrote a blog article that discussed another powerful feature called the "Duplicate Special" feature.  Although very useful, the Duplicate Special feature is still quite limited in its use and in this article, I will explain the multitude of benefits in using the Scenario Manager to help you track the various cases you would like to model.

 The Scenario Manager can be accessed from the Tools menu within each AFT product and is shown in Figure 1 below.  The Scenario Manager contains many useful functions such as:

  • Ability to create new child scenarios
  • Rename scenarios
  • Clone (i.e., copy) scenarios either with or without their children scenarios
  • Child scenarios can be promoted to the same level as their parent scenario
  • Scenarios can be inserted as "new parent scenarios" above a selected scenario
    • Very useful when it is desired to clone the Base Scenario with many child scenarios
  • Particular scenarios can be saved as their own separate model files (with or without children)
  • Scenario specific notes can be added for each scenario
  • Scenarios can be re-ordered within the scenario tree

Figure 1 - The Scenario Manager window

Figure 1 - The Scenario Manager window, accessed from the Tools menu.

All of the functionality of the Scenario Manager can also be accessed directly within the Quick Access Panel.

The power of the Scenario Manager is not only limited to the Scenario Manager window itself.  The Scenario Manager capabilities also extends to the Model Data window, perfoming Batch Runs of multiple scenarios, and the Output window.

The model input for multiple scenarios can be compared to each other with the Model Data window's Multi-Scenario Input feature.  With this feature, the model input of a child scenario can be compared with the model input of its parent and grandparent scenarios as long as each scenario exists in a direct ancestral lineage.  Changes in the model input will be highlighted in green, as shown in Figure 2 below.

Figure 2 - Model input compared for scenarios

Figure 2 - Model input compared for scenarios in a direct ancestral lineage using the Multi-Scenario Input feature of the Model Data window.

 When multiple scenarios exist, they can all be ran together in a sequential Batch Run fashion, allowing the engineer to devote their focus to other things while the solver is running a whole slew of scenarios.  Batch Runs can be initiated by going to the File menu and then selecting "Start Batch Run".  The Batch Run window appears and scenarios within the current model can be added or models in different model files can be ran in a batch fashion as well.  Clicking on the "Add Scenarios" button allows selection of specific scenarios that need to be ran in batch mode.  Setting up a Batch Run is shown in Figure 3.

Figure 3 - Setting up a Batch Run

Figure 3 - Setting up a Batch Run from the File menu in order to run multiple scenarios sequentially.

Finally, once all of the scenarios have been ran through the solver, the Output results of each scenario can be compared side by side with each other.  Multi-Scenario formatting can be setup in the Output Control window and the desired scenarios to compare output together can be added to the Output results.  Each scenario can also be color-coded, making it easier to distinguish the results from different scenarios.  Figure 4 shows the output results of several scenarios compared in a well-organized and color-coded fashion.

Figure 4 - Output results of multiple scenarios

Figure 4 - Output results of multiple scenarios compared against each other using Multi-Scenario formatting with the Output Results window.

In regards to data propagation with the Scenario Manager, changes made in a parent scenario will be passed downwards to child scenarios.  The changes will be inherited by the child scenarios if the specific input parameters for the child scenarios have not already been changed.  If a specific input parameter for a child scenario has already been changed, then the child scenario will become disconnected from the parent scenario for that specific input parameter.  Therefore, any changes to the same input parameter type in the parent scenario will NOT be inherited by that child or its children.  Changes made to child scenarios will NOT propagate upwards to parent scenarios.

It is possible to re-link disconnected child scenarios to their parent scenarios and it can be accomplished in two different ways.  One way is to simply change the disconnected input parameter of the child scenario to be the same value as that of the parent scenario.  The other way, as shown in Figure 5, is to click on the "Copy Data From" drop-down menu in the Property window and choose "Parent Pipe Data" (or "Parent Junction Data" for junctions), and then select the input parameter from the list that is to be reconnected.  After this has been done, the parent and child scenarios will then be re-linked, and changes made to the parent scenario will then be passed to the child scenario for the newly re-linked input parameter again.

Figure 5 - Re-Linking child scenario input parameters

Figure 5 - Re-Linking child scenario input parameters with parent input data using the "Copy Data From" drop-down menu.

Just remember, "With Great Power, Comes Great Responsibility".  So be sure to pay close attention to what you are doing so that an unintended change does not get propagated to all the child scenarios.  Nor would you want all the child scenarios to become very disorganized and disconnected such that it would become very cumbersome to get all the scenarios re-connected again.  Exercising a high level of caution and attention can help one prevent the misuse of the powerful capabilities of the Scenario Manager.

Overall, when using AFT software, it is very important to become intimately familiar and comfortable with using the Scenario Manager, as it will dramatically save you lots of time and will help you maintain a high level of organization for the several different cases you may want to model.

Defining & Running 12 Scenarios in Less than 10 Mi...
Making the Most of Your Extra Time

Related Posts

 

Comments

No comments made yet. Be the first to submit a comment
Guest
Saturday, 26 September 2020

By accepting you will be accessing a service provided by a third-party external to https://www.aft.com/

© 2020 Applied Flow Technology