Log in

Login to your account

Username *
Password *
Remember Me

Create an account

Fields marked with an asterisk (*) are required.
Name *
Username *
Password *
Verify password *
Email *
Verify email *
Captcha *
Reload Captcha

Modeling Component Resistance Curves

Posted in AFT Fathom, AFT Arrow, AFT Titan, AFT Impulse, AFT Mercury

A variety of resistance modeling methods are available within AFT software, including constant or variable K values for a wide variety of components, K or Cv for valves. Also, for most components, you may directly model a resistance curve. This is especially handy when you pressure drop (or head loss) vs. flow data from the component manufacturer or test data. Whether you're modeling a valve, spray discharge, orifice or general component junction, you'll find this option on the Loss Model tab of the junction specification window listed as "Resistance Curve". Clicking the button will highlight an 'Enter Curve Data' button, which will take you to a curve fit window.

At the top of the window you'll find options to set the flow parameter to a volumetric, mass flow, velocity or Reynolds basis, and the units. Next to that will be the option to set the loss parameter to either pressure or head, and, again, the units to be used. Below will be the Raw Data table where you may enter flow and loss data pairs. There are a number of ways to enter this data. Of course you may simply type the data in directly. Immediately above the Raw Data table you'll find the Fill As Quadratic button.

There are a large number of components whose resistance closely varies as the square of flow, and can thus be accurately modeled with a quadratic (or square law) curve. Let's say you have a pressure drop at a reference flow for a heat exchanger. Enter the flow and pressure drop, then click 'Fill As Quadratic'. Two data pairs will be automatically generated - a 0-0 pair and another pair with twice the flow that you input and four times the loss.

Other ways to enter data into the Raw Data are available using the Edit Table button immediately below. You can import data from a file (comma, space or tab delimited) or simply paste the data in from, say, Excel. If the source data is available electronically, you usually easily bring it into Excel, where you can arrange it in flow-loss columns. Select the data range, press ctl-C, then select Paste from the Edit Table button.

Once the data is in the table, click the Generate Curve Fit Now button to generate the polynomial equation. Curve fit order may range from 0 to 4. Alternatively, you use the entered data as interpolated X-Y data, where the exact data points are used and intermediate points are linearly interpolated.

© 2021 Applied Flow Technology